On Fri, Sep 18, 2020 at 4:55 PM Marco Elver <elver@xxxxxxxxxx> wrote: > > On Fri, Aug 14, 2020 at 07:26PM +0200, Andrey Konovalov wrote: > > This is a preparatory commit for the upcoming addition of a new hardware > > tag-based (MTE-based) KASAN mode. > > > > Group shadow-related KASAN function declarations and only define them > > for the two existing software modes. > > > > No functional changes for software modes. > > > > Signed-off-by: Andrey Konovalov <andreyknvl@xxxxxxxxxx> > > --- > > include/linux/kasan.h | 44 ++++++++++++++++++++++++++----------------- > > 1 file changed, 27 insertions(+), 17 deletions(-) > > > > diff --git a/include/linux/kasan.h b/include/linux/kasan.h > > index bd5b4965a269..44a9aae44138 100644 > > --- a/include/linux/kasan.h > > +++ b/include/linux/kasan.h > [...] > > +static inline int kasan_add_zero_shadow(void *start, unsigned long size) > > +{ > > + return 0; > > +} > > +static inline void kasan_remove_zero_shadow(void *start, > > + unsigned long size) > > +{} > > Readability suggestion (latest checkpatch.pl allows up to 100 cols): > > -static inline void kasan_remove_zero_shadow(void *start, > - unsigned long size) > -{} > +static inline void kasan_remove_zero_shadow(void *start, unsigned long size) {} Will do in v3, thanks!