On Tue 25-08-20 14:28:14, Matthew Wilcox wrote: > On Tue, Aug 25, 2020 at 02:33:24PM +0200, Jan Kara wrote: > > On Mon 24-08-20 18:36:39, Matthew Wilcox wrote: > > > We already have functions in filemap which take a pagevec, eg > > > page_cache_delete_batch() and delete_from_page_cache_batch(). > > > > Right but those are really pretty internal helper functions so I don't > > think they form or strong precedence. > > To be honest, I saw that as being the way forward for the page cache APIs. > If we're going to use a batching mechanism, it should be pagevecs, and > it should be built into the page cache interfaces rather than hanging > out off on the side. > > > > So if we're going to merge the two functions, it seems more natural to > > > have it in filemap.c and called find_get_entries(), but I'm definitely > > > open to persuasion on this! > > > > I agree that having non-trivial xarray code in mm/swap.c isn't attractive > > either. Dunno, I dislike the inconsistency between find_get_pages() and > > find_get_entries() you create but they aren't completely consistent anyway > > so I can live with that. Or we can just leave the pagevec_lookup_entries() > > wrapper and the API will stay consistent... > > I was thinking about this some more [1] [2]. I think we can get to the > point where find_get_pages(), find_get_entries() and find_get_pages_tag() > (and all their variants) end up taking a pagevec as their last argument. > > Also, I was thinking that all these names are wrong. Really, they're > mapping_get_pages(), mapping_get_entries() and mapping_get_marked_pages(). > So maybe I should move in that direction. Well, as I wrote to you in one of the replies. IMO pagevec unnecessarily complicate matters and we should rather have for_each_mapping_page() and for_each_mapping_entry() magic macros that hide pagevecs inside. Most of users process returned pages/entries one by one so these macros would simplify them. So it would seem better to me to go more into this direction than to spread pagevecs... > [1] https://lore.kernel.org/lkml/20200824214841.17132-1-willy@xxxxxxxxxxxxx/ > [2] https://lore.kernel.org/lkml/20200824183424.4222-1-willy@xxxxxxxxxxxxx/ Honza -- Jan Kara <jack@xxxxxxxx> SUSE Labs, CR