Re: [PATCH v4 10/11] mm/memory-failure: remove a wrapper for alloc_migration_target()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue 07-07-20 17:03:50, Vlastimil Babka wrote:
> On 7/7/20 1:48 PM, Michal Hocko wrote:
> > On Tue 07-07-20 16:44:48, Joonsoo Kim wrote:
> >> From: Joonsoo Kim <iamjoonsoo.kim@xxxxxxx>
> >> 
> >> There is a well-defined standard migration target callback. Use it
> >> directly.
> >> 
> >> Signed-off-by: Joonsoo Kim <iamjoonsoo.kim@xxxxxxx>
> >> ---
> >>  mm/memory-failure.c | 18 ++++++------------
> >>  1 file changed, 6 insertions(+), 12 deletions(-)
> >> 
> >> diff --git a/mm/memory-failure.c b/mm/memory-failure.c
> >> index 609d42b6..3b89804 100644
> >> --- a/mm/memory-failure.c
> >> +++ b/mm/memory-failure.c
> >> @@ -1677,16 +1677,6 @@ int unpoison_memory(unsigned long pfn)
> >>  }
> >>  EXPORT_SYMBOL(unpoison_memory);
> >>  
> >> -static struct page *new_page(struct page *p, unsigned long private)
> >> -{
> >> -	struct migration_target_control mtc = {
> >> -		.nid = page_to_nid(p),
> >> -		.gfp_mask = GFP_USER | __GFP_MOVABLE | __GFP_RETRY_MAYFAIL,
> >> -	};
> >> -
> >> -	return alloc_migration_target(p, (unsigned long)&mtc);
> >> -}
> >> -
> >>  /*
> >>   * Safely get reference count of an arbitrary page.
> >>   * Returns 0 for a free page, -EIO for a zero refcount page
> >> @@ -1793,6 +1783,10 @@ static int __soft_offline_page(struct page *page)
> >>  	const char *msg_page[] = {"page", "hugepage"};
> >>  	bool huge = PageHuge(page);
> >>  	LIST_HEAD(pagelist);
> >> +	struct migration_target_control mtc = {
> >> +		.nid = NUMA_NO_NODE,
> >> +		.gfp_mask = GFP_USER | __GFP_MOVABLE | __GFP_RETRY_MAYFAIL,
> >> +	};
> > 
> > Is NUMA_NO_NODE really intended here? The original code has preferred to
> > stay on the same node.
> 
> The alloc_migration_target() interprets NUMA_NO_NODE as a request to call
> page_to_nid(), so we don't need these thin wrappers that do just that. I have
> suggested this in v3 review and it's mentioned in 06/11.

Ohh, right. I just lost that piece of information on the way. It
wouldn't hurt to keep page_to_nid here for readability though.
-- 
Michal Hocko
SUSE Labs




[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux