From: Joonsoo Kim <iamjoonsoo.kim@xxxxxxx> This patchset clean-up the migration target allocation functions. * Changes on v3 - do not introduce alloc_control for hugetlb functions - do not change the signature of migrate_pages() - rename alloc_control to migration_target_control * Changes on v2 - add acked-by tags - fix missing compound_head() call for patch #3 - remove thisnode field on alloc_control and use __GFP_THISNODE directly - fix missing __gfp_mask setup for patch "mm/hugetlb: do not modify user provided gfp_mask" * Cover-letter Contributions of this patchset are: 1. unify two hugetlb alloc functions. As a result, one is remained. 2. make one external hugetlb alloc function to internal one. 3. unify three functions for migration target allocation. The patchset is based on next-20200621. The patchset is available on: https://github.com/JoonsooKim/linux/tree/cleanup-migration-target-allocation-v3.00-next-20200621 Thanks. Joonsoo Kim (8): mm/page_isolation: prefer the node of the source page mm/migrate: move migration helper from .h to .c mm/hugetlb: unify migration callbacks mm/hugetlb: make hugetlb migration callback CMA aware mm/migrate: make a standard migration target allocation function mm/gup: use a standard migration target allocation callback mm/mempolicy: use a standard migration target allocation callback mm/page_alloc: remove a wrapper for alloc_migration_target() include/linux/hugetlb.h | 13 +++--------- include/linux/migrate.h | 34 ++++++------------------------ mm/gup.c | 56 +++++++------------------------------------------ mm/hugetlb.c | 53 ++++++++++++++++++++-------------------------- mm/internal.h | 9 +++++++- mm/memory-failure.c | 8 +++++-- mm/memory_hotplug.c | 14 ++++++++----- mm/mempolicy.c | 29 ++++++------------------- mm/migrate.c | 45 +++++++++++++++++++++++++++++++++++++-- mm/page_alloc.c | 9 ++++++-- mm/page_isolation.c | 5 ----- 11 files changed, 119 insertions(+), 156 deletions(-) -- 2.7.4