Re: [PATCH] mm: use __func__ replace function name

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon, Jun 15, 2020 at 07:28:54PM +0800, hui yang wrote:
> From: YangHui <yanghui.def@xxxxxxxxx>
> 
> it's much better to use __func__

Not always.  This message is reporting the improper usage of a public API.
If we were to, for example, split the function into two and rename this
half of it __kmem_cache_destroy(), we'd still want this message to say
kmem_cache_destroy.

I don't think we should apply this change, and if you have similar patches
in mind, I'd like to see a more detailed argument than "it's better".

> @@ -960,8 +960,8 @@ void kmem_cache_destroy(struct kmem_cache *s)
>  		err = shutdown_cache(s);
>  
>  	if (err) {
> -		pr_err("kmem_cache_destroy %s: Slab cache still has objects\n",
> -		       s->name);
> +		pr_err("%s: %s: Slab cache still has objects\n",
> +		       __func__, s->name);
>  		dump_stack();
>  	}
>  out_unlock:




[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux