On 06/24/2011 09:49 AM, Andrea Righi wrote:
diff --git a/mm/truncate.c b/mm/truncate.c index 3a29a61..90f3a97 100644 --- a/mm/truncate.c +++ b/mm/truncate.c @@ -312,20 +312,27 @@ void truncate_inode_pages(struct address_space *mapping, loff_t lstart) EXPORT_SYMBOL(truncate_inode_pages); /** - * invalidate_mapping_pages - Invalidate all the unlocked pages of one inode + * __invalidate_mapping_pages - Invalidate all the unlocked pages of one inode * @mapping: the address_space which holds the pages to invalidate * @start: the offset 'from' which to invalidate * @end: the offset 'to' which to invalidate (inclusive) + * @force: always drop pages when true (otherwise, reduce cache eligibility)
I don't like the parameter name "force". The parameter determines whether or not pages actually get invalidated, so I'm guessing the parameter name should reflect the function... Maybe something like "invalidate"? -- All rights reversed -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Fight unfair telecom internet charges in Canada: sign http://stopthemeter.ca/ Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>