On 09.05.20 02:45, Andrew Morton wrote: > On Thu, 26 Mar 2020 18:07:29 +0000 James Morse <james.morse@xxxxxxx> wrote: > >> Memory added to the system by hotplug has a 'System RAM' resource created >> for it. This is exposed to user-space via /proc/iomem. >> >> This poses problems for kexec on arm64. If kexec decides to place the >> kernel in one of these newly onlined regions, the new kernel will find >> itself booting from a region not described as memory in the firmware >> tables. >> >> Arm64 doesn't have a structure like the e820 memory map that can be >> re-written when memory is brought online. Instead arm64 uses the UEFI >> memory map, or the memory node from the DT, sometimes both. We never >> rewrite these. >> >> Allow an architecture to specify a different name for these hotplug >> regions. >> >> ... >> >> --- a/mm/memory_hotplug.c >> +++ b/mm/memory_hotplug.c >> @@ -42,6 +42,10 @@ >> #include "internal.h" >> #include "shuffle.h" >> >> +#ifndef MEMORY_HOTPLUG_RES_NAME >> +#define MEMORY_HOTPLUG_RES_NAME "System RAM" >> +#endif >> + >> /* >> * online_page_callback contains pointer to current page onlining function. >> * Initially it is generic_online_page(). If it is required it could be >> @@ -103,7 +107,7 @@ static struct resource *register_memory_resource(u64 start, u64 size) >> { >> struct resource *res; >> unsigned long flags = IORESOURCE_SYSTEM_RAM | IORESOURCE_BUSY; >> - char *resource_name = "System RAM"; >> + char *resource_name = MEMORY_HOTPLUG_RES_NAME; >> >> if (start + size > max_mem_size) >> return ERR_PTR(-E2BIG); > > I suppose we should do this as well: > > --- a/mm/memory_hotplug.c~mm-memory_hotplug-allow-arch-override-of-non-boot-memory-resource-names-fix > +++ a/mm/memory_hotplug.c > @@ -129,7 +129,8 @@ static struct resource *register_memory_ > resource_name, flags); > > if (!res) { > - pr_debug("Unable to reserve System RAM region: %016llx->%016llx\n", > + pr_debug("Unable to reserve " MEMORY_HOTPLUG_RES_NAME > + " region: %016llx->%016llx\n", > start, start + size); > return ERR_PTR(-EEXIST); > } > > It assumes that MEMORY_HOTPLUG_RES_NAME will be a literal string, which > is the case in [3/3]. @Andrew, as discussed in this thread already [1], I suggest to drop this series from -mm tree for now. [1] https://lkml.kernel.org/r/2e3419b2-d00c-51c3-9b45-9de114608cdf@xxxxxxx -- Thanks, David / dhildenb