From: "Matthew Wilcox (Oracle)" <willy@xxxxxxxxxxxxx> I really don't like that this feature is called page poisoning. We already had something called page poisoning and it's when you detect a memory error in a page. This is just uninitialised pages. I don't have the time right now to do that renaming, so just fix some of the other problems I found with the implementation. This hasn't been checked out by the build-bots yet, so there may be some missing conversions. Matthew Wilcox (Oracle) (5): mm: Constify a lot of struct page arguments mm: Rename PF_POISONED_PAGE to page_poison_check mm: Remove casting away of constness mm: Check for page poison in both page_to_nid implementations mm: Check page poison before finding a head page include/linux/mm.h | 32 +++++++------- include/linux/mm_types.h | 11 +---- include/linux/mmdebug.h | 4 +- include/linux/page-flags.h | 74 ++++++++++++++++----------------- include/linux/page_owner.h | 6 +-- include/linux/page_ref.h | 4 +- include/linux/pageblock-flags.h | 2 +- include/linux/pagemap.h | 4 +- include/linux/swap.h | 2 +- mm/debug.c | 6 +-- mm/hugetlb.c | 6 +-- mm/page_alloc.c | 12 +++--- mm/page_owner.c | 2 +- mm/sparse.c | 1 + mm/swapfile.c | 6 +-- mm/util.c | 6 +-- 16 files changed, 85 insertions(+), 93 deletions(-) -- 2.25.1