On Mon, Apr 6, 2020 at 10:59 AM Waiman Long <longman@xxxxxxxxxx> wrote: > > I have actually been thinking about that. I saw a couple of cases in the > crypto code where a memzero_explicit() is followed by kfree(). Those can > be replaced by kfree_sensitive. Ack. Doing that (and renaming kvzfree) should be a fairly straightforward coccinelle patch. Somebody (maybe you) asked whether we could just use kvfree_sensitive() for everything, We probably could. The extra test is cheap - much cheaper than the memzero_explicit(). That said, _there_ I think that consistency with regular kfree/kvfree naming means that we might as well keep separate names, and keep the kmalloc->kfree_sensitive and kvmalloc->kvfree_sensitive pairing. Even if technically we could do with just the one function that works for both cases. Linus