On Mon, Apr 6, 2020 at 9:12 AM Joe Perches <joe@xxxxxxxxxxx> wrote: > > While I agree with Linus about the __ prefix, > the z is pretty common and symmetric to all > the <foo>zalloc uses. Yes, we have a pattern of 'z' for zero. But the _operation_ isn't symmetric. "kzalloc()" has absolutely _nothing_ to do with "kzfree()". They are not some kind of "opposite symmetric operation". They are totally different. They have absolutely nothing in common. So using the same naming is wrong. They have one implementation detail that looks superficially similar ("zero the area"), but even that superficial similarity is actually completely false. They may both use "memset()", but in one case it is correct and makes sense, and in the other case it's actually a bug waiting to happen, and you really should use that "memzero_explicit()", which is a very very different operation from a normal memzero(). So even the implementation isn't really validly similar, but even if it had been, the _reason_ for doing so is completely different. They simply don't really pair up in any way. Linus