David Rientjes <rientjes@xxxxxxxxxx> wrote: > > +static inline void kvfree_sensitive(const void *addr, size_t len) > > +{ > > + if (addr) { > > Shouldn't this be if (unlikely(ZERO_OR_NULL_PTR(addr))? You've reversed the logic - it needs a '!' there. David