On Wed, 2020-02-26 at 14:04 -0800, Dave Hansen wrote: > On 2/5/20 10:19 AM, Yu-cheng Yu wrote: > > diff --git a/drivers/gpu/drm/i915/gvt/gtt.c b/drivers/gpu/drm/i915/gvt/gtt.c > > index 4b04af569c05..e467ca182633 100644 > > --- a/drivers/gpu/drm/i915/gvt/gtt.c > > +++ b/drivers/gpu/drm/i915/gvt/gtt.c > > @@ -1201,7 +1201,7 @@ static int split_2MB_gtt_entry(struct intel_vgpu *vgpu, > > } > > > > /* Clear dirty field. */ > > - se->val64 &= ~_PAGE_DIRTY; > > + se->val64 &= ~_PAGE_DIRTY_BITS; > > > > ops->clear_pse(se); > > ops->clear_ips(se); > > Are the i915 maintainers on cc? > > Shouldn't this use pte_mkclean() instead of open-coding? These functions look like a set of pte_* equivalent for the driver. They all use the bits directly. Add its maintainers to cc. Yu-cheng