2020년 3월 19일 (목) 오전 2:52, Johannes Weiner <hannes@xxxxxxxxxxx>님이 작성: > > On Tue, Mar 17, 2020 at 02:41:50PM +0900, js1304@xxxxxxxxx wrote: > > From: Joonsoo Kim <iamjoonsoo.kim@xxxxxxx> > > > > In current implementation, newly created or swap-in anonymous page > > is started on active list. Growing active list results in rebalancing > > active/inactive list so old pages on active list are demoted to inactive > > list. Hence, the page on active list isn't protected at all. > > > > Following is an example of this situation. > > > > Assume that 50 hot pages on active list. Numbers denote the number of > > pages on active/inactive list (active | inactive). > > > > 1. 50 hot pages on active list > > 50(h) | 0 > > > > 2. workload: 50 newly created (used-once) pages > > 50(uo) | 50(h) > > > > 3. workload: another 50 newly created (used-once) pages > > 50(uo) | 50(uo), swap-out 50(h) > > > > This patch tries to fix this issue. > > Like as file LRU, newly created or swap-in anonymous pages will be > > inserted to the inactive list. They are promoted to active list if > > enough reference happens. This simple modification changes the above > > example as following. > > > > 1. 50 hot pages on active list > > 50(h) | 0 > > > > 2. workload: 50 newly created (used-once) pages > > 50(h) | 50(uo) > > > > 3. workload: another 50 newly created (used-once) pages > > 50(h) | 50(uo), swap-out 50(uo) > > > > As you can see, hot pages on active list would be protected. > > > > Note that, this implementation has a drawback that the page cannot > > be promoted and will be swapped-out if re-access interval is greater than > > the size of inactive list but less than the size of total(active+inactive). > > To solve this potential issue, following patch will apply workingset > > detection that is applied to file LRU some day before. > > > > Signed-off-by: Joonsoo Kim <iamjoonsoo.kim@xxxxxxx> > > Acked-by: Johannes Weiner <hannes@xxxxxxxxxxx> > > > -void lru_cache_add_active_or_unevictable(struct page *page, > > +void lru_cache_add_inactive_or_unevictable(struct page *page, > > struct vm_area_struct *vma) > > { > > + bool evictable; > > + > > VM_BUG_ON_PAGE(PageLRU(page), page); > > > > - if (likely((vma->vm_flags & (VM_LOCKED | VM_SPECIAL)) != VM_LOCKED)) > > - SetPageActive(page); > > - else if (!TestSetPageMlocked(page)) { > > + evictable = (vma->vm_flags & (VM_LOCKED | VM_SPECIAL)) != VM_LOCKED; > > + if (!evictable && !TestSetPageMlocked(page)) { > > Minor point, but in case there is a v4: `unevictable` instead of > !evictable would be a bit easier to read, match the function name, > PageUnevictable etc. Okay. Looks like v4 is needed so I will change it as you said. Thanks.