From: "Matthew Wilcox (Oracle)" <willy@xxxxxxxxxxxxx> These are all things that I noticed while working on the THP patches, but all stand alone as useful MM cleanups. Andrew, please consider applying. There's two extra patches in here compared to v1; I separated out the patch renaming the arguments to find_subpage() from the patch converting it to use hpage_nr_pages(), and I added a patch to check PageTail() in hpage_nr_pages() for the !THP case. Patch 5 (Remove CONFIG_TRANSPARENT_HUGE_PAGECACHE) adds the missing hunk that Alex Duyck pointed out. Patch 8 (pagecache_get_page documentation) also renames the 'offset' parameter to 'index'. Original series here: https://lore.kernel.org/linux-mm/20200303041125.19358-1-willy@xxxxxxxxxxxxx/ Matthew Wilcox (Oracle) (8): mm: Use vm_fault error code directly mm: Rename arguments to find_subpage mm: Check PageTail in hpage_nr_pages even when !THP mm: Optimise find_subpage for !THP mm: Remove CONFIG_TRANSPARENT_HUGE_PAGECACHE mm: Use VM_BUG_ON_PAGE in clear_page_dirty_for_io mm: Unexport find_get_entry mm: Rewrite pagecache_get_page documentation include/linux/huge_mm.h | 6 ++++- include/linux/pagemap.h | 15 +++++++----- include/linux/shmem_fs.h | 10 +------- mm/Kconfig | 6 +---- mm/filemap.c | 52 +++++++++++++++++++--------------------- mm/huge_memory.c | 2 +- mm/khugepaged.c | 12 ++++------ mm/memory.c | 5 ++-- mm/page-writeback.c | 2 +- mm/rmap.c | 2 +- mm/shmem.c | 36 ++++++++++++++-------------- 11 files changed, 67 insertions(+), 81 deletions(-) -- 2.25.1