On 03/16/20 at 12:00pm, David Hildenbrand wrote: > On 16.03.20 11:21, Baoquan He wrote: > > This change makes populate_section_memmap()/depopulate_section_memmap > > much simpler. > > > > Suggested-by: Michal Hocko <mhocko@xxxxxxxxxx> > > Signed-off-by: Baoquan He <bhe@xxxxxxxxxx> > > Reviewed-by: David Hildenbrand <david@xxxxxxxxxx> > > Acked-by: Michal Hocko <mhocko@xxxxxxxx> > > --- > > v3->v4: > > Split the old v3 into two patches, to carve out the using 'nid' > > as preferred node to allocate memmap into a separate patch. This > > is suggested by Michal, and the carving out is put in patch 2. > > > > v2->v3: > > Remove __GFP_NOWARN and use array_size when calling kvmalloc_node() > > per Matthew's comments. > > http://lkml.kernel.org/r/20200312141749.GL27711@MiWiFi-R3L-srv > > > > mm/sparse.c | 27 +++------------------------ > > 1 file changed, 3 insertions(+), 24 deletions(-) > > > > diff --git a/mm/sparse.c b/mm/sparse.c > > index e747a238a860..d01d09cc7d99 100644 > > --- a/mm/sparse.c > > +++ b/mm/sparse.c > > @@ -719,35 +719,14 @@ static int fill_subsection_map(unsigned long pfn, unsigned long nr_pages) > > struct page * __meminit populate_section_memmap(unsigned long pfn, > > unsigned long nr_pages, int nid, struct vmem_altmap *altmap) > > { > > - struct page *page, *ret; > > - unsigned long memmap_size = sizeof(struct page) * PAGES_PER_SECTION; > > - > > - page = alloc_pages(GFP_KERNEL|__GFP_NOWARN, get_order(memmap_size)); > > - if (page) > > - goto got_map_page; > > - > > - ret = vmalloc(memmap_size); > > - if (ret) > > - goto got_map_ptr; > > - > > - return NULL; > > -got_map_page: > > - ret = (struct page *)pfn_to_kaddr(page_to_pfn(page)); > > -got_map_ptr: > > - > > - return ret; > > + return kvmalloc(array_size(sizeof(struct page), > > + PAGES_PER_SECTION), GFP_KERNEL); > > FWIW, this is what I meant: > > return kvmalloc(array_size(sizeof(struct page), > PAGES_PER_SECTION), GFP_KERNEL); Since there's another parameter, I didn't indent it with sizeof. But Pankaj and Matthew have added other two votes on this, I will change it, thanks.