On 03/13/20 at 04:04pm, David Hildenbrand wrote: > On 12.03.20 15:17, Baoquan He wrote: > > This change makes populate_section_memmap()/depopulate_section_memmap > > much simpler. > > > > Suggested-by: Michal Hocko <mhocko@xxxxxxxxxx> > > Signed-off-by: Baoquan He <bhe@xxxxxxxxxx> > > --- > > v2->v3: > > Remove __GFP_NOWARN and use array_size when calling kvmalloc_node() > > per Matthew's comments. > > > > mm/sparse.c | 27 +++------------------------ > > 1 file changed, 3 insertions(+), 24 deletions(-) > > > > diff --git a/mm/sparse.c b/mm/sparse.c > > index bf6c00a28045..bb99633575b5 100644 > > --- a/mm/sparse.c > > +++ b/mm/sparse.c > > @@ -734,35 +734,14 @@ static void free_map_bootmem(struct page *memmap) > > struct page * __meminit populate_section_memmap(unsigned long pfn, > > unsigned long nr_pages, int nid, struct vmem_altmap *altmap) > > { > > - struct page *page, *ret; > > - unsigned long memmap_size = sizeof(struct page) * PAGES_PER_SECTION; > > - > > - page = alloc_pages(GFP_KERNEL|__GFP_NOWARN, get_order(memmap_size)); > > - if (page) > > - goto got_map_page; > > - > > - ret = vmalloc(memmap_size); > > - if (ret) > > - goto got_map_ptr; > > - > > - return NULL; > > -got_map_page: > > - ret = (struct page *)pfn_to_kaddr(page_to_pfn(page)); > > -got_map_ptr: > > - > > - return ret; > > + return kvmalloc_node(array_size(sizeof(struct page), > > + PAGES_PER_SECTION), GFP_KERNEL, nid); > > > Indentation of the parameters looks wrong/weird. Maybe just calculate > memmap_size outside of the call, makes it easier to read IMHO. I'll fix the indentation issue. Adding variable memmap_size seems not so necessary. > > Apart from that, looks good to me. > > Reviewed-by: David Hildenbrand <david@xxxxxxxxxx> > > -- > Thanks, > > David / dhildenb