On 3/12/20 5:02 AM, hui yang wrote: > From: YangHui <yanghui.def@xxxxxxxxx> > > if there has not "+" , it will show below: > DMA: 305*4kB (UMCH).....5*2048kB (C) 13*4096kB (C) = 67196kB > actually it's an addition expression > so we should add "+" > > Signed-off-by: YangHui <yanghui.def@xxxxxxxxx> Yeah but I think it's quite clear even without the '+' which would just make the output longer harder to read, IMHO. > --- > mm/page_alloc.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/mm/page_alloc.c b/mm/page_alloc.c > index 3c4eb75..d90b3d7 100644 > --- a/mm/page_alloc.c > +++ b/mm/page_alloc.c > @@ -5399,7 +5399,7 @@ void show_free_areas(unsigned int filter, nodemask_t *nodemask) > } > spin_unlock_irqrestore(&zone->lock, flags); > for (order = 0; order < MAX_ORDER; order++) { > - printk(KERN_CONT "%lu*%lukB ", > + printk(KERN_CONT "+%lu*%lukB ", > nr[order], K(1UL) << order); > if (nr[order]) > show_migration_types(types[order]); >