On Mon, Mar 09, 2020 at 03:06:46PM -0500, Eric W. Biederman wrote: > Christian Brauner <christian.brauner@xxxxxxxxxx> writes: > > > On Sun, Mar 08, 2020 at 04:36:55PM -0500, Eric W. Biederman wrote: > >> > >> These functions have very little to do with de_thread move them out > >> of de_thread an into flush_old_exec proper so it can be more clearly > >> seen what flush_old_exec is doing. > >> > >> Signed-off-by: "Eric W. Biederman" <ebiederm@xxxxxxxxxxxx> > >> --- > >> fs/exec.c | 10 +++++----- > >> 1 file changed, 5 insertions(+), 5 deletions(-) > >> > >> diff --git a/fs/exec.c b/fs/exec.c > >> index ff74b9a74d34..215d86f77b63 100644 > >> --- a/fs/exec.c > >> +++ b/fs/exec.c > >> @@ -1189,11 +1189,6 @@ static int de_thread(struct task_struct *tsk) > > > > While you're cleaning up de_thread() wouldn't it be good to also take > > the opportunity and remove the task argument from de_thread(). It's only > > ever used with current. Could be done in one of your patches or as a > > separate patch. > > How does that affect the code generation? The same way renaming "tsk" to "me" does. > > My sense is that computing current once in flush_old_exec is much > better than computing it in each function flush_old_exec calls. > I remember that computing current used to be not expensive but > noticable. > > For clarity I can see renaming tsk to me. So that it is clear we are > talking about the current process, and not some arbitrary process. For clarity since de_thread() uses "tsk" giving the impression that any task can be dethreaded while it's only ever used with current. It's just a suggestion since you're doing the rename tsk->me anyway it would fit with the series. You do whatever you want though. (I just remember that the same request was made once to changes I did: Don't pass current as arg when it's the only task passed.)