Re: [PATCH] mm/page_alloc: use free_area_empty() instead of open-coding

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Sun, Mar 08, 2020 at 08:01:45PM +0800, qiwuchen55@xxxxxxxxx wrote:
>  		if (alloc_harder &&
> -			!list_empty(&area->free_list[MIGRATE_HIGHATOMIC]))
> +		    !free_area_empty(area, MIGRATE_HIGHATOMIC))

I think these can now be one line?

Also, I think free_area_empty() and a number of related functions can move
from mmzone.h to mm/internal.h.  This will benefit all of us since mmzone.h
is included from mm.h and so is widely seen throughout the kernel.




[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux