On Mon, 2 Mar 2020, Anshuman Khandual wrote: > This adds the following new VMA flag wrappers which will replace current > open encodings across various places. This should not have any functional > implications. > > vma_is_dontdump() > vma_is_noreserve() > vma_is_special() > vma_is_locked() > vma_is_mergeable() > vma_is_softdirty() > vma_is_thp() > vma_is_nothp() Why?? Please don't. I am not at all keen on your 1/3 and 2/3 (some of us actually like to see what the VM_ flags are where they're used, without having to chase through scattered wrappers hiding them), but this 3/3 particularly upset me. There is a good reason for the (hideously named) is_vm_hugetlb_page(vma): to save "#ifdef CONFIG_HUGETLB_PAGE"s all over (though I suspect the same could have been achieved much more nicely by #define VM_HUGETLB 0); but hiding all flags in vma_is_whatever()s is counter-productive churn. Improved readability? Not to my eyes. Hugh