On Sat, Feb 29, 2020 at 11:43:17PM +0800, chenqiwu wrote: > On Sat, Feb 29, 2020 at 07:31:23AM -0800, Matthew Wilcox wrote: > > On Sat, Feb 29, 2020 at 11:25:49PM +0800, qiwuchen55@xxxxxxxxx wrote: > > > +++ b/mm/memory.c > > > @@ -1948,8 +1948,8 @@ static inline int remap_p4d_range(struct mm_struct *mm, pgd_t *pgd, > > > * remap_pfn_range - remap kernel memory to userspace > > > * @vma: user vma to map to > > > * @addr: target user address to start at > > > - * @pfn: physical address of kernel memory > > > - * @size: size of map area > > > + * @pfn: remap pfn converted by physical address of kernel memory > > > > I think that's actually worse. How about: > > > > * @pfn: Page Frame Number of memory. > > Hmm... I think "Page Frame Number of kernel memory" should be better. I disagree. We already know the memory is kernel memory from the first line. Repeating this information in the parameter description isn't particularly helpful.