On Fri, Feb 14, 2020 at 05:26:56PM -0500, Christian Borntraeger wrote: > +enum access_type { > + MAKE_ACCESSIBLE_GENERIC, > + MAKE_ACCESSIBLE_GET, > + MAKE_ACCESSIBLE_GET_FAST, > + MAKE_ACCESSIBLE_WRITEBACK > +}; > #ifndef HAVE_ARCH_MAKE_PAGE_ACCESSIBLE > -static inline int arch_make_page_accessible(struct page *page) > +static inline int arch_make_page_accessible(struct page *page, int where) If we want to make this distinction, wouldn't it be simpler to just use different function names, like arch_make_page_accessible_for_writeback arch_make_page_accessible_for_gup etc. Bye, Ulrich -- Dr. Ulrich Weigand GNU/Linux compilers and toolchain Ulrich.Weigand@xxxxxxxxxx