This is a cleanup patch. Rename compaction_zonelist_suitable to compaction_nodelist_suitable. Signed-off-by: Pengfei Li <fly@xxxxxxxxxxx> --- include/linux/compaction.h | 2 +- mm/compaction.c | 2 +- mm/page_alloc.c | 2 +- 3 files changed, 3 insertions(+), 3 deletions(-) diff --git a/include/linux/compaction.h b/include/linux/compaction.h index 4b898cdbdf05..3ba55eb7c353 100644 --- a/include/linux/compaction.h +++ b/include/linux/compaction.h @@ -177,7 +177,7 @@ static inline bool compaction_withdrawn(enum compact_result result) } -bool compaction_zonelist_suitable(struct alloc_context *ac, int order, +bool compaction_nodelist_suitable(struct alloc_context *ac, int order, int alloc_flags); extern int kcompactd_run(int nid); diff --git a/mm/compaction.c b/mm/compaction.c index d9f42e18991c..91581ab1d593 100644 --- a/mm/compaction.c +++ b/mm/compaction.c @@ -2036,7 +2036,7 @@ enum compact_result compaction_suitable(struct zone *zone, int order, return ret; } -bool compaction_zonelist_suitable(struct alloc_context *ac, int order, +bool compaction_nodelist_suitable(struct alloc_context *ac, int order, int alloc_flags) { struct nlist_traverser t; diff --git a/mm/page_alloc.c b/mm/page_alloc.c index 5c96d1ecd643..3987b8e97158 100644 --- a/mm/page_alloc.c +++ b/mm/page_alloc.c @@ -3967,7 +3967,7 @@ should_compact_retry(struct alloc_context *ac, int order, int alloc_flags, * to work with, so we retry only if it looks like reclaim can help. */ if (compaction_needs_reclaim(compact_result)) { - ret = compaction_zonelist_suitable(ac, order, alloc_flags); + ret = compaction_nodelist_suitable(ac, order, alloc_flags); goto out; } -- 2.23.0