On 11/17/19 7:22 PM, linmiaohe wrote: > From: Miaohe Lin <linmiaohe@xxxxxxxxxx> > > The jump labels try_prev and none are not really needed > in find_mergeable_anon_vma(), eliminate them to improve > readability. > -v2: > Fix commit descriptions and further simplify the code > as suggested by David Hildenbrand and John Hubbard. Admin point: the above three lines will end up in the commit log, which is probably not what you intended. If, instead, you put them below the "---" line, then they will act as comments about the patch, and won't show up in the commit log. thanks, -- John Hubbard NVIDIA > > Reviewed-by: David Hildenbrand <david@xxxxxxxxxx> > Reviewed-by: John Hubbard <jhubbard@xxxxxxxxxx> > Signed-off-by: Miaohe Lin <linmiaohe@xxxxxxxxxx> > --- > mm/mmap.c | 27 +++++++++++++-------------- > 1 file changed, 13 insertions(+), 14 deletions(-) > > diff --git a/mm/mmap.c b/mm/mmap.c > index 4d4db76a07da..ff02c23fd375 100644 > --- a/mm/mmap.c > +++ b/mm/mmap.c > @@ -1276,26 +1276,25 @@ static struct anon_vma *reusable_anon_vma(struct vm_area_struct *old, struct vm_ > */ > struct anon_vma *find_mergeable_anon_vma(struct vm_area_struct *vma) > { > - struct anon_vma *anon_vma; > + struct anon_vma *anon_vma = NULL; > struct vm_area_struct *near; > > + /* Try next first. */ > near = vma->vm_next; > - if (!near) > - goto try_prev; > + if (near) { > + anon_vma = reusable_anon_vma(near, vma, near); > + if (anon_vma) > + return anon_vma; > + } > > - anon_vma = reusable_anon_vma(near, vma, near); > - if (anon_vma) > - return anon_vma; > -try_prev: > + /* Try prev next. */ > near = vma->vm_prev; > - if (!near) > - goto none; > + if (near) > + anon_vma = reusable_anon_vma(near, near, vma); > > - anon_vma = reusable_anon_vma(near, near, vma); > - if (anon_vma) > - return anon_vma; > -none: > /* > + * We might reach here with anon_vma == NULL if we can't find > + * any reusable anon_vma. > * There's no absolute need to look only at touching neighbours: > * we could search further afield for "compatible" anon_vmas. > * But it would probably just be a waste of time searching, > @@ -1303,7 +1302,7 @@ struct anon_vma *find_mergeable_anon_vma(struct vm_area_struct *vma) > * We're trying to allow mprotect remerging later on, > * not trying to minimize memory used for anon_vmas. > */ > - return NULL; > + return anon_vma; > } > > /* >