On Thu, 10 Oct 2019, Shyam Saini wrote: > This will help error related to ERR_PTR stand out better. Maybe make ZERO_SIZE_PTR an ERRNO value instead? Then allow ERR_PTRs to be used instead of ZERO_SIZE_PTRs ERRNO_ZERO_OBJECT or something like that? > */ > -#define ZERO_SIZE_PTR ((void *)16) #define ZERO_SIZE_PTR ((void *)-ERRNO_ZERO_OBJECT) > + > +#define ZERO_OR_NULL_PTR(x) ((unsigned long)(x) - 1 >= \ > + (unsigned long)ZERO_SIZE_PTR - 1) And call this something different?