On Sun, Aug 11, 2019 at 11:46 AM Uladzislau Rezki (Sony) <urezki@xxxxxxxxx> wrote: > > Recently there was introduced RB_DECLARE_CALLBACKS_MAX template. > One of the callback, to be more specific *_compute_max(), calculates > a maximum scalar value of node against its left/right sub-tree. > > To simplify the code and improve readability we can switch and > make use of max3() macro that makes the code more transparent. > > Signed-off-by: Uladzislau Rezki (Sony) <urezki@xxxxxxxxx> Thanks. The change is correct but I think I prefer it the "before" version. My reasons are: - I don't have a strong style preference either way - it's the same amount of code either way, admittedly more modular in your proposal, but also with more indirection (compute_max refers to get_max and max3). The indirection doesn't hinder readability but IMO it makes it harder to be confident that the compiler will generate quality code, compared to the "before" approach which just lays down all the pieces in a linear way. - A quick check shows that the proposed change generates larger code for mm/interval_tree.o: 2757 0 0 2757 ac5 mm/interval_tree.o 2533 0 0 2533 9e5 mm/interval_tree.o.orig This does not happen for every RB_DECLARE_CALLBACKS_MAX use, lib/interval_tree.o in particular seems to be fine. But it does go towards my gut feeling that the change trusts the compiler/optimizer more than I want to. - Slight loss of generality. The "before" code only assumes that the RBAUGMENTED field can be compared using "<" ; the "after" code also assumes that the minimum value is 0. While this covers the current uses, I would prefer not to have that limitation.