Hi, This series of patches is to reduce the size of struct vmap_area. Since the members of struct vmap_area are not being used at the same time, it is possible to reduce its size by placing several members that are not used at the same time in a union. The first 4 patches did some preparatory work for this and improved readability. The fifth patch is the main patch, it did the work of rewriting vmap_area. More details can be obtained from the commit message. Thanks, Pengfei Pengfei Li (5): mm/vmalloc.c: Introduce a wrapper function of insert_vmap_area() mm/vmalloc.c: Introduce a wrapper function of insert_vmap_area_augment() mm/vmalloc.c: Rename function __find_vmap_area() for readability mm/vmalloc.c: Modify function merge_or_add_vmap_area() for readability mm/vmalloc.c: Rewrite struct vmap_area to reduce its size include/linux/vmalloc.h | 28 +++++--- mm/vmalloc.c | 144 +++++++++++++++++++++++++++------------- 2 files changed, 117 insertions(+), 55 deletions(-) -- 2.21.0