On Tue, Jun 11, 2019 at 03:36:53PM +0100, Vladimir Murzin wrote: > It looks like NOMMU ports tend to define those. For ARM they are: > > #define __swp_type(x) (0) > #define __swp_offset(x) (0) > #define __swp_entry(typ,off) ((swp_entry_t) { ((typ) | ((off) << 7)) }) > #define __pte_to_swp_entry(pte) ((swp_entry_t) { pte_val(pte) }) > #define __swp_entry_to_pte(x) ((pte_t) { (x).val }) > > Anyway, I have no strong opinion on which is better :) It just seems a lot easier to stub out swapops.h rather than providing stubs in each arch so that inlines which we are never going to use can build. I can look into dropping this from the other nommu ports for the next merge window, though.