Hi Dan, Thank you very much for your review, my comments below: On Mon, May 6, 2019 at 2:01 PM Dan Williams <dan.j.williams@xxxxxxxxx> wrote: > > On Mon, May 6, 2019 at 10:57 AM Dave Hansen <dave.hansen@xxxxxxxxx> wrote: > > > > > -static inline void remove_memory(int nid, u64 start, u64 size) {} > > > +static inline bool remove_memory(int nid, u64 start, u64 size) > > > +{ > > > + return -EBUSY; > > > +} > > > > This seems like an appropriate place for a WARN_ONCE(), if someone > > manages to call remove_memory() with hotplug disabled. I decided not to do WARN_ONCE(), in all likelihood compiler will simply optimize this function out, but with WARN_ONCE() some traces of it will remain. > > > > BTW, I looked and can't think of a better errno, but -EBUSY probably > > isn't the best error code, right? -EBUSY is the only error that is returned in case of error by real remove_memory(), so I think it is OK to keep it here. > > > > > -void remove_memory(int nid, u64 start, u64 size) > > > +/** > > > + * remove_memory > > > + * @nid: the node ID > > > + * @start: physical address of the region to remove > > > + * @size: size of the region to remove > > > + * > > > + * NOTE: The caller must call lock_device_hotplug() to serialize hotplug > > > + * and online/offline operations before this call, as required by > > > + * try_offline_node(). > > > + */ > > > +void __remove_memory(int nid, u64 start, u64 size) > > > { > > > + > > > + /* > > > + * trigger BUG() is some memory is not offlined prior to calling this > > > + * function > > > + */ > > > + if (try_remove_memory(nid, start, size)) > > > + BUG(); > > > +} > > > > Could we call this remove_offline_memory()? That way, it makes _some_ > > sense why we would BUG() if the memory isn't offline. It is this particular code path, the second one: remove_memory(), actually tries to remove memory and returns failure if it can't. So, I think the current name is OK. > > Please WARN() instead of BUG() because failing to remove memory should > not be system fatal. As mentioned earlier, I will keep BUG(), because existing code does that, and there is no good handling of this code to return on error. Thank you, Pavel