On Mon, Apr 22, 2019 at 08:20:10PM +0800, Peter Xu wrote: > On Fri, Apr 19, 2019 at 11:02:53AM -0400, Jerome Glisse wrote: > > [...] > > > > > > + if (uffd_wp_resolve) { > > > > > + /* If the fault is resolved already, skip */ > > > > > + if (!pte_uffd_wp(*pte)) > > > > > + continue; > > > > > + page = vm_normal_page(vma, addr, oldpte); > > > > > + if (!page || page_mapcount(page) > 1) { > > > > > + struct vm_fault vmf = { > > > > > + .vma = vma, > > > > > + .address = addr & PAGE_MASK, > > > > > + .page = page, > > > > > + .orig_pte = oldpte, > > > > > + .pmd = pmd, > > > > > + /* pte and ptl not needed */ > > > > > + }; > > > > > + vm_fault_t ret; > > > > > + > > > > > + if (page) > > > > > + get_page(page); > > > > > + arch_leave_lazy_mmu_mode(); > > > > > + pte_unmap_unlock(pte, ptl); > > > > > + ret = wp_page_copy(&vmf); > > > > > + /* PTE is changed, or OOM */ > > > > > + if (ret == 0) > > > > > + /* It's done by others */ > > > > > + continue; > > > > > > > > This is wrong if ret == 0 you still need to remap the pte before > > > > continuing as otherwise you will go to next pte without the page > > > > table lock for the directory. So 0 case must be handled after > > > > arch_enter_lazy_mmu_mode() below. > > > > > > > > Sorry i should have catch that in previous review. > > > > > > My fault to not have noticed it since the very beginning... thanks for > > > spotting that. > > > > > > I'm squashing below changes into the patch: > > > > > > Well thinking of this some more i think you should use do_wp_page() and > > not wp_page_copy() it would avoid bunch of code above and also you are > > not properly handling KSM page or page in the swap cache. Instead of > > duplicating same code that is in do_wp_page() it would be better to call > > it here. > > Yeah it makes sense to me. Then here's my plan: > > - I'll need to drop previous patch "export wp_page_copy" since then > it'll be not needed > > - I'll introduce another patch to split current do_wp_page() and > introduce function "wp_page_copy_cont" (better suggestion on the > naming would be welcomed) which contains most of the wp handling > that'll be needed for change_pte_range() in this patch and isolate > the uffd handling: > > static vm_fault_t do_wp_page(struct vm_fault *vmf) > __releases(vmf->ptl) > { > struct vm_area_struct *vma = vmf->vma; > > if (userfaultfd_pte_wp(vma, *vmf->pte)) { > pte_unmap_unlock(vmf->pte, vmf->ptl); > return handle_userfault(vmf, VM_UFFD_WP); > } > > return do_wp_page_cont(vmf); > } > > Then I can probably use do_wp_page_cont() in this patch. Instead i would keep the do_wp_page name and do: static vm_fault_t do_userfaultfd_wp_page(struct vm_fault *vmf) { ... // what you have above return do_wp_page(vmf); } Naming wise i think it would be better to keep do_wp_page() as is. Cheers, Jérôme