* Peter Zijlstra <peterz@xxxxxxxxxxxxx> [2011-04-18 18:55:00]: > On Fri, 2011-04-01 at 20:05 +0530, Srikar Dronamraju wrote: > > +/* > > + * @reg: reflects the saved state of the task > > + * @vaddr: the virtual address to jump to. > > + * Return 0 on success or a -ve number on error. > > + */ > > +void set_ip(struct pt_regs *regs, unsigned long vaddr) > > +{ > > + regs->ip = vaddr; > > +} > > Since we have the cross-architecture function: > instruction_pointer(struct pt_regs*) to read the thing, this ought to be > called set_instruction_pointer(struct pt_regs*, unsigned long) or > somesuch. Okay, will rename set_ip to set_instruction_pointer. -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxxx For more info on Linux MM, see: http://www.linux-mm.org/ . Fight unfair telecom internet charges in Canada: sign http://stopthemeter.ca/ Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>