On Wed, Mar 20, 2019 at 06:13:18PM +0800, Baoquan He wrote: > + if (!memmap) { > + ret = -ENOMEM; > + goto out2; Documentation/process/coding-style: Choose label names which say what the goto does or why the goto exists. An example of a good name could be ``out_free_buffer:`` if the goto frees ``buffer``. Avoid using GW-BASIC names like ``err1:`` and ``err2:``, as you would have to renumber them if you ever add or remove exit paths, and they make correctness difficult to verify anyway.