Re: [PATCH v7 2/3] mm: Move buddy list manipulations into helpers

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon 07-01-19 15:21:16, Dan Williams wrote:
> In preparation for runtime randomization of the zone lists, take all
> (well, most of) the list_*() functions in the buddy allocator and put
> them in helper functions. Provide a common control point for injecting
> additional behavior when freeing pages.

Looks good in general and it actually makes the code more readable.
One nit below

[...]
> +static inline void rmv_page_order(struct page *page)
> +{
> +	__ClearPageBuddy(page);
> +	set_page_private(page, 0);
> +}
> +

I guess we do not really need this helper and simply squash it to its
only user.

Acked-by: Michal Hocko <mhocko@xxxxxxxx>

-- 
Michal Hocko
SUSE Labs




[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux