On 01/16/2019 06:14 PM, Michal Hocko wrote: > On Wed 16-01-19 04:30:18, Matthew Wilcox wrote: >> On Wed, Jan 16, 2019 at 07:57:03AM +0100, Michal Hocko wrote: >>> On Wed 16-01-19 11:51:32, Anshuman Khandual wrote: >>>> All architectures have been defining their own PGALLOC_GFP as (GFP_KERNEL | >>>> __GFP_ZERO) and using it for allocating page table pages. This causes some >>>> code duplication which can be easily avoided. GFP_KERNEL allocated and >>>> cleared out pages (__GFP_ZERO) are required for page tables on any given >>>> architecture. This creates a new generic GFP flag flag which can be used >>>> for any page table page allocation. Does not cause any functional change. >>>> >>>> GFP_PGTABLE is being added into include/asm-generic/pgtable.h which is the >>>> generic page tabe header just to prevent it's potential misuse as a general >>>> allocation flag if included in include/linux/gfp.h. >>> >>> I haven't reviewed the patch yet but I am wondering whether this is >>> really worth it without going all the way down to unify the common code >>> and remove much more code duplication. Or is this not possible for some >>> reason? >> >> Exactly what I suggested doing in response to v1. >> >> Also, the approach taken here is crazy. x86 has a feature that no other >> architecture has bothered to implement yet -- accounting page tables >> to the process. Yet instead of spreading that goodness to all other >> architectures, Anshuman has gone to more effort to avoid doing that. > > Yes, I believe the only reason this is x86 only is that each arch would > have to be tweaked separately. So a cleanup in _that_ regard would be > helpful. There is no real reason to have ptes accounted only for x86. > There might be some exceptions but well, our asm-generic allows to opt > in for generic implementation or override it with a special one. The > later should be an exception rather than the rule. Fair enough. So we seem to have agreement over __GFP_ACCOUNT for user page tables but not for the kernel. But should we accommodate __GFP_RETRY_MAYFAIL or drop them altogether (including multi order allocation requests) ?