On 1/10/19 9:12 PM, Pingfan Liu wrote: > The current acpi_table_upgrade() relies on initrd_start, but this var is "var" meaning variable? Could you please go back and try to ensure you spell out all the words you are intending to write? I think "topo" probably means "topology", but it's a really odd word to use for changing the arguments of a function, so I'm not sure. There are a couple more of these in this set. > only valid after relocate_initrd(). There is requirement to extract the > acpi info from initrd before memblock-allocator can work(see [2/4]), hence > acpi_table_upgrade() need to accept the input param directly. "[2/4]" It looks like you quickly resent this set without updating the patch descriptions. > diff --git a/drivers/acpi/tables.c b/drivers/acpi/tables.c > index 61203ee..84e0a79 100644 > --- a/drivers/acpi/tables.c > +++ b/drivers/acpi/tables.c > @@ -471,10 +471,8 @@ static DECLARE_BITMAP(acpi_initrd_installed, NR_ACPI_INITRD_TABLES); > > #define MAP_CHUNK_SIZE (NR_FIX_BTMAPS << PAGE_SHIFT) > > -void __init acpi_table_upgrade(void) > +void __init acpi_table_upgrade(void *data, size_t size) > { > - void *data = (void *)initrd_start; > - size_t size = initrd_end - initrd_start; > int sig, no, table_nr = 0, total_offset = 0; > long offset = 0; > struct acpi_table_header *table; I know you are just replacing some existing variables, but we have a slightly higher standard for naming when you actually have to specify arguments to a function. Can you please give these proper names?