On Mon, Dec 03, 2018 at 12:16:11PM +0100, David Hildenbrand wrote: > Let's use the easier to read (and not mess up) variants: > - Use DEVICE_ATTR_RO > - Use DEVICE_ATTR_WO > - Use DEVICE_ATTR_RW > instead of the more generic DEVICE_ATTR() we're using right now. > > We have to rename most callback functions. By fixing the intendations we > can even save some LOCs. > > Cc: Greg Kroah-Hartman <gregkh@xxxxxxxxxxxxxxxxxxx> > Cc: "Rafael J. Wysocki" <rafael@xxxxxxxxxx> > Cc: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> > Cc: Ingo Molnar <mingo@xxxxxxxxxx> > Cc: Pavel Tatashin <pasha.tatashin@xxxxxxxxxx> > Cc: Oscar Salvador <osalvador@xxxxxxxx> > Cc: Michal Hocko <mhocko@xxxxxxxxxx> > Cc: Wei Yang <richard.weiyang@xxxxxxxxx> > Signed-off-by: David Hildenbrand <david@xxxxxxxxxx> > Reviewed-by: Wei Yang <richard.weiyang@xxxxxxxxx> > --- > drivers/base/memory.c | 79 ++++++++++++++++++++----------------------- > 1 file changed, 36 insertions(+), 43 deletions(-) Thanks, I'll take this through my tree. greg k-h