On Fri 05-10-18 19:49:48, john.hubbard@xxxxxxxxx wrote: > From: John Hubbard <jhubbard@xxxxxxxxxx> > > Introduces put_user_page(), which simply calls put_page(). > This provides a way to update all get_user_pages*() callers, > so that they call put_user_page(), instead of put_page(). > > Also introduces put_user_pages(), and a few dirty/locked variations, > as a replacement for release_pages(), and also as a replacement > for open-coded loops that release multiple pages. > These may be used for subsequent performance improvements, > via batching of pages to be released. > > This prepares for eventually fixing the problem described > in [1], and is following a plan listed in [2], [3], [4]. > > [1] https://lwn.net/Articles/753027/ : "The Trouble with get_user_pages()" > > [2] https://lkml.kernel.org/r/20180709080554.21931-1-jhubbard@xxxxxxxxxx > Proposed steps for fixing get_user_pages() + DMA problems. > > [3]https://lkml.kernel.org/r/20180710082100.mkdwngdv5kkrcz6n@xxxxxxxxxxxxxx > Bounce buffers (otherwise [2] is not really viable). > > [4] https://lkml.kernel.org/r/20181003162115.GG24030@xxxxxxxxxxxxxx > Follow-up discussions. > > CC: Matthew Wilcox <willy@xxxxxxxxxxxxx> > CC: Michal Hocko <mhocko@xxxxxxxxxx> > CC: Christopher Lameter <cl@xxxxxxxxx> > CC: Jason Gunthorpe <jgg@xxxxxxxx> > CC: Dan Williams <dan.j.williams@xxxxxxxxx> > CC: Jan Kara <jack@xxxxxxx> > CC: Al Viro <viro@xxxxxxxxxxxxxxxxxx> > CC: Jerome Glisse <jglisse@xxxxxxxxxx> > CC: Christoph Hellwig <hch@xxxxxxxxxxxxx> > CC: Ralph Campbell <rcampbell@xxxxxxxxxx> > Signed-off-by: John Hubbard <jhubbard@xxxxxxxxxx> > --- > include/linux/mm.h | 48 ++++++++++++++++++++++++++++++++++++++++++++-- > 1 file changed, 46 insertions(+), 2 deletions(-) Looks good to me. You can add: Reviewed-by: Jan Kara <jack@xxxxxxx> Just one nit below: > +/* Pages that were pinned via get_user_pages*() should be released via > + * either put_user_page(), or one of the put_user_pages*() routines > + * below. > + */ Multi-line comments usually follow formatting: /* * Some text here * and more text here... */ Honza -- Jan Kara <jack@xxxxxxxx> SUSE Labs, CR