On Fri, Oct 5, 2018 at 4:19 PM Miguel Ojeda <miguel.ojeda.sandonis@xxxxxxxxx> wrote: > > Hi Souptick, > > On Fri, Oct 5, 2018 at 12:01 PM Souptick Joarder <jrdr.linux@xxxxxxxxx> wrote: > > > > The final goal is to remove vm_insert_page by converting it to > > vmf_insert_page. But to do that we have to first introduce the > > new API which is similar to vm_insert_page (for non #PF). I tried this by > > introducing vm_insert_kmem_page ( * identical as vm_insert_page > > except API name *) in this patch. But this looks like a bad approach. > > We are going in circles here. That you want to convert vm_insert_page > to vmf_insert_page for the PF case is fine and understood. However, > you don't *need* to introduce a new name for the remaining non-PF > cases if the function is going to be the exact same thing as before. > You say "The final goal is to remove vm_insert_page", but you haven't > justified *why* you need to remove that name. > > Now, if we want to rename the function for some reason (e.g. avoid > confusion with vmf_insert_page), that is fine but is another topic. It > may be or not a good idea, but it is orthogonal to the vmf_ work. > Matthew, on this regard, told you that you shouldn't duplicate > functions. If you want a rename, do so; but don't copy the code. In > other words: nobody said introducing the vm_insert_kmem_page name is a > bad idea -- what Matthew told you is that *duplicating* vm_insert_page > just for that is bad. > > Further, you are copying the code (if I understand your thought > process) because you want to change the callers of non-PF first, and > then do the "full conversion from vm_* to vmf_*". However, that is > confusing, because there is no need to change non-PF callers of > vm_insert_page since they don't care about the new vmf_* functions. > > Instead, the proper way of doing this is: > > 1. Introduce the vmf_* API > 2. Change all PF-users users to that (leaving all non-PF ones > untouched!) -- if this is too big, you can split this patch into > several patches, one per subsystem, etc. We are done with step 2. All the PF-users are converted to use vmf_insert_page. ( Ref - linux-next-20181005) > 3. Remove the vm_* functions (except the ones that are still used in > non-PF contexts, e.g. vm_insert_page) Step 3 is part of step 2. Already done. > > Then, optionally, if you want to rename the function for the remaining > non-PF users: > > 4. Rename vm_insert_page (justifying why the current name is > confusing *on its own merits*). > > Otherwise, if you want to pursue Matthew's idea: > > 4. Introduce the vm_insert_range (possibly leveraging > vm_insert_page, or not; you have to see what is best). > 5. Replace those callers that can take advantage of vm_insert_range > 6. Remove vm_insert_page and replace callers with vm_insert_range > (only if it is not worth to keep vm_insert_range, again justifying it > *on its own merits*) Step 4 to 6, going to do it. It is part of plan now :-) > > As you see, these are all logical step-by-step improvements, without > duplicating functions temporarily, leaving temporary changes or > changing current callers to new APIs for unrelated reasons (i.e. no > need to introduce vm_insert_kmem_page simply to do a "conversion" to > vmf_). > > Cheers, > Miguel