On 9/12/18 2:11 AM, Michal Hocko wrote:
On Tue 11-09-18 19:29:21, Matthew Wilcox wrote:
On Tue, Sep 11, 2018 at 04:35:03PM -0700, Yang Shi wrote:
[...]
I didn't get to read the patch yet.
If you guys think this is the better way I could convert my patches to
go this way. It is simple to do the conversion.
Thanks,
Yang
And, Michal prefers have VM_HUGETLB and VM_PFNMAP handled separately for
safe and bisectable sake, which needs call the regular do_munmap().
That can be introduced and then taken out ... indeed, you can split this into
many patches, starting with this:
+ if (tmp->vm_file)
+ downgrade = false;
to only allow this optimisation for anonymous mappings at first.
or add a helper function to check for special cases and make the
downgrade behavior conditional on it.