On Tue, Aug 21, 2018 at 8:15 PM, Johannes Weiner <hannes@xxxxxxxxxxx> wrote: > On Tue, Aug 21, 2018 at 08:11:44AM +0300, Konstantin Khlebnikov wrote: >> On Sat, Aug 18, 2018 at 4:22 AM, Matthew Wilcox <willy@xxxxxxxxxxxxx> wrote: >> > On Fri, Aug 17, 2018 at 04:18:34PM -0700, Roman Gushchin wrote: >> >> - scan = div64_u64(scan * fraction[file], >> >> - denominator); >> >> + if (scan > 1) >> >> + scan = div64_u64(scan * fraction[file], >> >> + denominator); >> > >> > Wouldn't we be better off doing a div_round_up? ie: >> > >> > scan = div64_u64(scan * fraction[file] + denominator - 1, denominator); >> > >> > although i'd rather hide that in a new macro in math64.h than opencode it >> > here. >> >> All numbers here should be up to nr_pages * 200 and fit into unsigned long. >> I see no reason for u64. If they overflow then u64 wouldn't help either. > > It is nr_pages * 200 * recent_scanned, where recent_scanned can be up > to four times of what's on the LRUs. That can overflow a u32 with even > small amounts of memory. Ah, this thing is inverted because it aims to proportional reactivation rate rather than the proportional pressure to reclaimable pages. That's not obvious. I suppose this should be in comment above it. Well, at least denominator should fit into unsigned long. So full 64/64 division is redundant.