On Mon 30-07-18 15:37:18, osalvador@xxxxxxxxxxxxxxxxxx wrote: > From: Oscar Salvador <osalvador@xxxxxxx> > > is_dev_zone() is using zone_id() to check if the zone is ZONE_DEVICE. > zone_id() looks pretty much the same as zone_idx(), and while the use of > zone_idx() is quite spread in the kernel, zone_id() is only being > used by is_dev_zone(). > > This patch removes zone_id() and makes is_dev_zone() use zone_idx() > to check the zone, so we do not have two things with the same > functionality around. Yes this looks like a pointless code duplication. I guess Dan just wasn't aware of zone_idx() macro. > Signed-off-by: Oscar Salvador <osalvador@xxxxxxx> Acked-by: Michal Hocko <mhocko@xxxxxxxx> > --- > include/linux/mmzone.h | 31 ++++++++++++------------------- > 1 file changed, 12 insertions(+), 19 deletions(-) > > diff --git a/include/linux/mmzone.h b/include/linux/mmzone.h > index 83b1d11e90eb..dbe7635c33dd 100644 > --- a/include/linux/mmzone.h > +++ b/include/linux/mmzone.h > @@ -755,25 +755,6 @@ static inline bool pgdat_is_empty(pg_data_t *pgdat) > return !pgdat->node_start_pfn && !pgdat->node_spanned_pages; > } > > -static inline int zone_id(const struct zone *zone) > -{ > - struct pglist_data *pgdat = zone->zone_pgdat; > - > - return zone - pgdat->node_zones; > -} > - > -#ifdef CONFIG_ZONE_DEVICE > -static inline bool is_dev_zone(const struct zone *zone) > -{ > - return zone_id(zone) == ZONE_DEVICE; > -} > -#else > -static inline bool is_dev_zone(const struct zone *zone) > -{ > - return false; > -} > -#endif > - > #include <linux/memory_hotplug.h> > > void build_all_zonelists(pg_data_t *pgdat); > @@ -824,6 +805,18 @@ static inline int local_memory_node(int node_id) { return node_id; }; > */ > #define zone_idx(zone) ((zone) - (zone)->zone_pgdat->node_zones) > > +#ifdef CONFIG_ZONE_DEVICE > +static inline bool is_dev_zone(const struct zone *zone) > +{ > + return zone_idx(zone) == ZONE_DEVICE; > +} > +#else > +static inline bool is_dev_zone(const struct zone *zone) > +{ > + return false; > +} > +#endif > + > /* > * Returns true if a zone has pages managed by the buddy allocator. > * All the reclaim decisions have to use this function rather than > -- > 2.13.6 > -- Michal Hocko SUSE Labs