On Wed, Jul 25, 2018 at 8:15 AM Oscar Salvador <osalvador@xxxxxxxxxxxxxxxxxx> wrote: > > On Tue, Jul 24, 2018 at 07:55:19PM -0400, Pavel Tatashin wrote: > > update_defer_init() should be called only when struct page is about to be > > initialized. Because it counts number of initialized struct pages, but > > there we may skip struct pages if there is some mirrored memory. > > > > So move, update_defer_init() after checking for mirrored memory. > > > > Also, rename update_defer_init() to defer_init() and reverse the return > > boolean to emphasize that this is a boolean function, that tells that the > > reset of memmap initialization should be deferred. > > > > Make this function self-contained: do not pass number of already > > initialized pages in this zone by using static counters. > > > > Signed-off-by: Pavel Tatashin <pasha.tatashin@xxxxxxxxxx> > > --- > > mm/page_alloc.c | 40 ++++++++++++++++++++-------------------- > > 1 file changed, 20 insertions(+), 20 deletions(-) > > > > diff --git a/mm/page_alloc.c b/mm/page_alloc.c > > index cea749b26394..86c678cec6bd 100644 > > --- a/mm/page_alloc.c > > +++ b/mm/page_alloc.c > > @@ -306,24 +306,28 @@ static inline bool __meminit early_page_uninitialised(unsigned long pfn) > > } > > > > /* > > - * Returns false when the remaining initialisation should be deferred until > > + * Returns true when the remaining initialisation should be deferred until > > * later in the boot cycle when it can be parallelised. > > */ > > -static inline bool update_defer_init(pg_data_t *pgdat, > > - unsigned long pfn, unsigned long zone_end, > > - unsigned long *nr_initialised) > > +static inline bool defer_init(int nid, unsigned long pfn, unsigned long end_pfn) > > { > > + static unsigned long prev_end_pfn, nr_initialised; > > + > > + if (prev_end_pfn != end_pfn) { > > + prev_end_pfn = end_pfn; > > + nr_initialised = 0; > > + } > Hi Pavel, > > What about a comment explaining that "if". > I am not the brightest one, so it took me a bit to figure out that we got that "if" there > because now that the variables are static, we need to somehow track whenever we change to > another zone. Hi Oscar, Hm, yeah a comment would be appropriate here. I will send an updated patch. I will also change the functions from inline to normal functions as Andrew pointed out: it is not a good idea to use statics in inline functions. Thank you, Pavel