On Thu 21-06-18 10:37:51, Johannes Weiner wrote: > On Thu, Jun 21, 2018 at 10:09:27AM +0200, Michal Hocko wrote: > > @@ -496,14 +496,14 @@ void mem_cgroup_print_oom_info(struct mem_cgroup *memcg, > > > > static inline void mem_cgroup_oom_enable(void) > > { > > - WARN_ON(current->memcg_may_oom); > > - current->memcg_may_oom = 1; > > + WARN_ON(current->in_user_fault); > > + current->in_user_fault = 1; > > } > > > > static inline void mem_cgroup_oom_disable(void) > > { > > - WARN_ON(!current->memcg_may_oom); > > - current->memcg_may_oom = 0; > > + WARN_ON(!current->in_user_fault); > > + current->in_user_fault = 0; > > } > > Would it make more sense to rename these to > mem_cgroup_enter_user_fault(), mem_cgroup_exit_user_fault()? OK, makes sense. It is less explicit about the oom behavior... > Other than that, this looks great to me. Thanks for the review! I will wait few days for other feedback and retest and repost then. -- Michal Hocko SUSE Labs