On Wed, 6 Jun 2018, Baoquan He wrote: > I am back porting Thomas's sl[a|u]b freelist randomization feature to > our distros, need go through slab code for better understanding. From > git log history, they were 'obj_offset' and 'obj_size'. Later on > 'obj_size' was renamed to 'object_size' in commit 3b0efdfa1e("mm, sl[aou]b: > Extract common fields from struct kmem_cache") which is from your patch. > With my understanding, I guess you changed that on purpose because > object_size is size of each object, obj_offset is for the whole cache, > representing the offset the real object starts to be stored. And putting > them separately is for better desribing them in code comment and > distinction, e.g 'object_size' is in "4) cache creation/removal", > while 'obj_offset' is put alone to indicate it's for the whole. obj_offset only applies when CONFIG_SLAB_DEBUG is set. Ok so that screwy name also indicates that something special goes on.