On 03/03, KOSAKI Motohiro wrote: > > > +static const char __user * > > +get_arg_ptr(const char __user * const __user *argv, int argc) > > +{ > > [argc, argv] is natural order to me than [argv, argc]. Yes... in fact, "argc" is misnamed here. It doesn't mean the number of arguments, it is the index in the array. Perhaps this should be [argv, nr]. > and "get_" prefix are usually used for reference count incrementing > function in linux. so, i _personally_ prefer to call "user_arg_ptr". Agreed, the name is ugly. I'll rename and resend keeping your reviewed-by. [2/4] > I _personally_ don't like "conditional". Its name is based on code logic. > It's unclear what mean "conditional". From data strucuture view, It is > "opaque userland pointer". I agree with any naming, just suggest a better name ;) [3/4] > > + struct conditional_ptr argv = { > > + .is_compat = true, .ptr.compat = __argv, > > + }; > > Please don't mind to compress a line. > > struct conditional_ptr argv = { > .is_compat = true, > .ptr.compat = __argv, > }; OK, will do. Thanks for review! Oleg. -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxxx For more info on Linux MM, see: http://www.linux-mm.org/ . Fight unfair telecom internet charges in Canada: sign http://stopthemeter.ca/ Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>