On Mon, 16 Apr 2018, Matthew Wilcox wrote: > struct { /* Slub */ > struct kmem_cache *slub_cache; > /* Dword boundary */ > void *slub_freelist; > unsigned short inuse; > unsigned short objects:15; > unsigned short frozen:1; > struct page *next; > #ifdef CONFIG_64BIT > int pobjects; > int pages; > #endif > short int pages; > short int pobjects; > #endif That looks better. > I'd want to change slob to use slob_list instead of ->lru. Or maybe even do > something radical like _naming_ the struct in the union so we don't have to > manually namespace the names of the elements. Hmmm... How would that look?