On Tue, Mar 13, 2018 at 07:24:37PM +0900, Sergey Senozhatsky wrote: > Hello Minchan, > > On (03/13/18 18:02), Minchan Kim wrote: > > Sorry for being late. > > I love this patchset! Just a minor below. > > :) > > [..] > > > + if (!huge_class_size) > > > + huge_class_size = zs_huge_class_size(); > > > > If it is static, we can do this in zram_init? I believe it's more readable in that > > it's never changed betweens zram instances. > > We need to have at least one pool, because pool decides where the > watermark is. At zram_init() stage we don't have a pool yet. We > zs_create_pool() in zram_meta_alloc() so that's why I put > zs_huge_class_size() there. I'm not in love with it, but that's > the only place where we can have it. Fair enough. Then what happens if client calls zs_huge_class_size without creating zs_create_pool? I think we should make zs_huge_class_size has a zs_pool as argument.