On Thu, Mar 08, 2018 at 03:56:30PM +0000, Kani, Toshi wrote: > On Wed, 2018-03-07 at 20:00 -0800, Matthew Wilcox wrote: > > On Wed, Mar 07, 2018 at 11:32:26AM -0700, Toshi Kani wrote: > > > +/** > > > + * pud_free_pmd_page - clear pud entry and free pmd page > > > + * > > > + * Returns 1 on success and 0 on failure (pud not cleared). > > > + */ > > > +int pud_free_pmd_page(pud_t *pud) > > > +{ > > > + return pud_none(*pud); > > > +} > > > > Wouldn't it be clearer if you returned 'bool' instead of 'int' here? > > I thought about it and decided to use 'int' since all other pud/pmd/pte > interfaces, such as pud_none() above, use 'int'. These interfaces were introduced before we had bool ... I suspect nobody's taken the time to go through and convert them all.