On Sat, Mar 03, 2018 at 07:44:36AM -0500, Jeff Layton wrote: > > - return root->gfp_mask & __GFP_BITS_MASK; > > + return root->gfp_mask & ((__GFP_BITS_MASK >> 4) << 4); > > Maybe phrase this in terms of a constant like GFP_ZONEMASK here? Would > this be more appropriate? Yeah, that's a better idea. This is only interim; once all radix tree users are converted to the xarray, we stop storing GFP flags here. So I hadn't put much thought into it, but I'll change it. -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>