Hi Sergey, On Mon, Feb 26, 2018 at 02:49:27PM +0900, Sergey Senozhatsky wrote: > > I think it's simple enough. :) > > Right. The changes are pretty trivial, that's why I kept then in > 2 simple patches. Besides, I didn't want to mix zsmalloc and zram > changes. As I said earlier, it's not thing we usually do, at least, MM. Anyway, I don't want to insist on it because it depends each person's point of view what's the better for review, git-bisect. > > > Can't zram ask to zsmalloc about what size is for hugeobject from? > > With that, zram can save the wartermark in itself and use it. > > What I mean is as follows, > > > > zram: > > size_t huge_size = _zs_huge_object(pool); > > .. > > .. > > if (comp_size >= huge_size) > > memcpy(dst, src, 4K); > > Yes, can do. My plan was to keep it completely internally to zsmalloc. > Who knows, it might become smart enough one day to do something more > than just size comparison. Any reason you used that leading underscore Let's do that in future if someone want it. :) > in _zs_huge_object()? Nope. It's just typo. Let's think better name. How about using zs_huge_size()? -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>